You are not logged in.

#1 2020-04-19 07:05:48

gerry_c89
Member
Registered: 2020-04-19
Posts: 10

problems with linux arm 32bit

Hi to all, i'm new on the forum, my name is Gerardo and write from Italy. I have installed nanodlp for linux arm on the original nanopi m1 from the wanhao d7 printer, the distro that i have used is Armbian_20.02.1_Nanopim1_buster_current_5.4.20. The web server work correctly but if i turn on the display with a calibration to view if the framebuffer work, nanodlp crash with this traceback on terminal:

2020/04/19 08:56:28.862377 {"Layer":"0","module":"Hardware","level":"Notice","msg":"Initializing build # 2667 - generic"}
2020/04/19 08:56:28.862860 {"Layer":"0","module":"SLAVE","level":"Error","msg":"Serial port could not be activated no such file or directory"}
2020/04/19 08:56:28.863535 {"Layer":"0","module":"Terminal","level":"Notice","msg":"Terminal Reader Activated"}
⇨ http server started on [::]:80
2020/04/19 08:56:28.899209 {"Layer":"0","module":"WIFI","level":"Error","msg":"No WIFI dongle has been found."}
2020/04/19 08:56:39.755979 {"Layer":"0","module":"Image","level":"Warning","msg":"Display layer public/plates/dynamic.png"}
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0x4cc008]

goroutine 97 [running]:
projects/printer/app/hw.ShowFrame(0x7950f4, 0x19, 0x7950f4)
        /home/shahin/go/src/projects/printer/app/hw/hardware.go:115 +0x140
created by projects/printer/app/web.projectorAction
        /home/shahin/go/src/projects/printer/app/web/projector.go:49 +0xf0
d7@nanopim1:~/nanodlp$

I have only installed the d7 profile and nothing else, the nanopi board is connected only on an external monitor and ethernet.
here is a debug data collect

sendspace.com/file/gcrebg

I have noticed that the framebuffer path on configuration is empty and i have tryed to fill with /dev/fb0 but nothing, same thing
Is possible a dependence problem, i don't know what libraries and packages wants nanodlp. i have find this apt-get row in the setup.sh of pi version

apt-get install libpng12-0 libpng-dev libpng16-16 usbmount pigpio ntfs-3g

the libraries and packages that i can found in the armbian repository are:

libpng-dev libpng16-16 ntfs-3g

pigpio obviusly is legacy for pi boards

I have typed on ssh this for test framebuffer and it work

cat /dev/random > /dev/fb0

the screen is filled with casual color pixels
I have also tried other distros like friendlyelec based on debian and ubuntu but nothing.

Last edited by gerry_c89 (2020-04-19 20:59:31)

Offline

#2 2020-04-22 19:22:11

Shahin
Administrator
Registered: 2016-02-17
Posts: 3,510

Re: problems with linux arm 32bit

Please, check the latest beta version.

Offline

#3 2020-04-23 03:08:31

gerry_c89
Member
Registered: 2020-04-19
Posts: 10

Re: problems with linux arm 32bit

Fantastic!!!! Work!!!!! Thanks a loooooooot!!!!

this is all the necessary for install nanodlp on original nanopi m1 board from wanhao d7 plus or wanhao d7 external box (is the same), the dgus display isn't compatible, i think is possible to mount a nextion display:

* all information on the board for possibe connection of the tft display that in the d7 plus is already connected with an header on the uart1 /dev/ttyS1, but is a dwin dgus display:
  - http://wiki.friendlyarm.com/wiki/index.php/NanoPi_M1

* Armbian_20.02.1_Nanopim1_buster_current_5.4.20 on sd, after bootloader load the kernel the blue led blink, at the first start the filesystem is automatically extended DON'T INTERRUPT
  - https://www.armbian.com/nanopi-m1/

* connect via ssh to the ip addres of the board and login (root, 1234), after create user d7

* open armbian-config in the terminal and change this values:
  - the cpu by default is overclocked to 1.39ghz, set the governor to 480-1200 on demand for the stock cpu specs
  - change the line in the bootenv for disable video console that is set "both" to default:
      * console=serial

  -  add this line at last to the bootenv for disable blinking cursor:
      * extraargs=vt.global_cursor_default=0

  - enable on the peripherals all usbhosts and all uarts (this require a reboot, you can do it later)
  - change locale to your language, timezone and keyboard map
  - install avahi
  - execute firmware update (this command lanch apt-get update and upgrade automatically)

* reboot (with reboot command, not detach power) and login with d7 user

* install this packages with aptitude:
  - sudo apt-get install libpng-dev libpng16-16

* usbmount isn't present in the repository and you have to compile it with dpkg if you use the usb with this commands:
  - cd /usr/src/
  - sudo git clone http://github.com/kgara/usbmount/ --depth 1
  - sudo apt-get install debhelper lockfile-progs
  - cd ./usbmount
  - sudo dpkg-buildpackage -us -uc -b
  - sudo dpkg -i ../usbmount_0.0.24_all.deb

* put the console on the home of d7:
  - cd /home/d7

* download nanodlp
  - wget http://www.nanodlp.com/download/nanodlp.arm.zip

* unzip with
  - unzip ./nanodlp.arm.zip -d ./nanodlp

* create a file with nano like this and save it:
  - sudo nano /etc/systemd/system/nanodlp.service
  --------------------file content----------------------
  - [Unit]
  - Description=NanoDLP service
  - After=systemd-user-sessions.service plymouth-quit-wait.service
  -
  - [Service]
  - WorkingDirectory=/home/d7/nanodlp
  - ExecStart=/bin/bash /home/d7/nanodlp/run.sh
  - Restart=always
  - RestartSec=5
  -
  - [Install]
  - WantedBy=multi-user.target

* enable the service with
  - sudo systemctl --now enable nanodlp

* the web interface is now accessible

* restore the d7 machine settings profile downloadable from the site
  - https://www.nanodlp.com/repo/

* in the machine settings enable advanced setup ad insert this line in framebuffer path:
  - /dev/fb0

* update to the latest beta and now you can configure all like a pi version

Last edited by gerry_c89 (2020-04-25 00:57:33)

Offline

#4 2020-04-27 06:20:30

gerry_c89
Member
Registered: 2020-04-19
Posts: 10

Re: problems with linux arm 32bit

Hi, definitively i have reach a good level of functionality, the profile on the site is very buggy, but still have some problems, the curing time not sync correctly from the start of the shutter (that is correct, power up at the end of movement) but from the start of the last z movement, the first layer is correct. I have edited the end gcode for move z axis on top, and if I resume from stop a print the count of curing begin from the movement and skip some layers making only axis movement. I have added here all the profiles uploaded to my thingverse account and a debug collect.

https://www.sendspace.com/file/inw0qb

https://www.thingiverse.com/thing:4311542

Last edited by gerry_c89 (2020-04-27 06:23:49)

Offline

#5 2020-04-30 19:03:15

gerry_c89
Member
Registered: 2020-04-19
Posts: 10

Re: problems with linux arm 32bit

I have tried to leave only one zmovement sync in the code of before layer section but nothing change, someone have some idea? Thanks.
Gerry

Offline

Board footer

Powered by FluxBB