You are not logged in.

#1 2022-07-19 17:15:26

elliot
Member
Registered: 2016-04-28
Posts: 108

Random NanoDLP printer "hanging" Please help

Hi,
I have a major problem that I have been trying to solve for several months with nanoDLP. I hope others can help solve this or point me in some directions I have not traveled.

The printer is a heavily modified mUVe. Originally RasPi3 and Marlin V1

Current Set up:
RasPi 4, 4GB, 8, 16 and 64GB cards (plenty of room)
RAMPS 1.4
Mega 2560

Sotware:
5672, 6025, 6033 versions most recently tried. Also ran (3077, 4055, 5267)
Marlin V2 (upgraded to work with recent software versions)

General issue:
The printer appears to hang or stop at completely random layers, 68 and above. Regardless of resin profile or software version. It used to run through older versions, 3077, 4055, etc. But now these do not work either. It is very perplexing. Usually software works or not, or in this case some sections where the gcode changes exposure times etc. But I have also run resin profiles that are quite simple - single exposure times etc. The error appears to be a communication error - where the printer is waiting for an Z_comp message. In testing, I removed these wait for messages, but it will occasionally hang or actually skip the exposures - even with significant delay time commands in place.

How I got here:
RasPi3b with older software was upgraded after experiencing stl models were all "corrupt" after slicing or became corrupt after printing.
Upgraded to RasPi4, and communication errors described above started
Rebuilt printer: New components for power-supply, Arduino, RAMPS, communication cables, and of course RasPi from above and SD cards. Including reloading software

Recently tried several different power supplies just to check, and this had little effect.

Thank you, this forum is always great with info and help!

Offline

Board footer

Powered by FluxBB