You are not logged in.

#1 2022-02-28 12:59:58

F.m
Member
Registered: 2017-12-22
Posts: 147

uv light engine control problem

Hi
i bought new uv light engine. the device bonds to /dev/usb/lp0 . i can turn it ON/OFF via SSH by "echo" command, but can not use [[Projector .....]] command. i set usb/serial port to /dev/usb/lp0 and correct baud rate but it didn't work. even with [[Exec sudo echo ......]] it didn't work.

Last edited by F.m (2022-02-28 13:28:30)

Offline

#2 2022-03-01 16:47:27

Shahin
Administrator
Registered: 2016-02-17
Posts: 3,517

Re: uv light engine control problem

Checkout end of line sequence for the project. Some may need /r/n or /n at the end of command.

Offline

#3 2022-03-02 06:12:51

F.m
Member
Registered: 2017-12-22
Posts: 147

Re: uv light engine control problem

tested that, didn't work. the log says:

serial port could not be activated, no such file or directory
usb port could not be activated invalid serial port

it seems /dev/usb/lp0 is not accessible. also in provided list for serial ports in nanodlp, /dev/usb/lp0 is not provided and i add it manually.

Last edited by F.m (2022-03-02 07:20:03)

Offline

#4 2022-03-09 14:35:11

F.m
Member
Registered: 2017-12-22
Posts: 147

Re: uv light engine control problem

Shahin do you have any idea to send command to projector via /dev/usb/lp0 , as i told you before nanodlp says that /dev/usb/lp0 is: usb port could not be activated invalid serial port

Offline

#5 2022-03-22 07:11:30

Shahin
Administrator
Registered: 2016-02-17
Posts: 3,517

Re: uv light engine control problem

lp0 indicate parallel (not serial) connection.

Offline

Board footer

Powered by FluxBB