You are not logged in.

#1 2021-07-24 06:20:57

Freakyliciousfishy
Member
Registered: 2021-07-21
Posts: 2

Nano support white brick and unexpected EOF solution

So at first I hated this program cause everything I tried slicing wouldn't generate any usable images when connected to the raspberry pi. All images were just a white screen. But I found a solution and it goes as follows.

This assumes you already have a raspberry pi running the latest nano dlp.

Step 1. To solve this problem you have to download nano dlp for your pc.

Step 2. Load the interface via the browser on the pc via going to 127.0.0.1:8080

Now your going to need your resin profiles from the nano dlp on the raspberry pi.

Step 3. Export the resin profile you want to use.( the green box with an arrow pointing to the upper right does this)

This downloads it to the pc

Step 4. Import the downloaded profile to the nano dlp. installation on the pcby going back to 127.0.0.1:8080 and going to resin profile.(the green plus sign does this)

Now you have a working profile on the pc ..

Step 5. Open nano support load something and go to the slicing portion of the interface. Add a printer of 127.0.0.1:8080

Step 6. Add your pi using its ip address.

Step 7. Make sure you are connected to 127.0.0.1:8080  and slice your model.

This utilizes your pc to slice the model quickly and generates usable images

Step 8. Now connect to you pi by selecting it in nano dlp.

Step 9. Use the little arrow to send the plate to your pi. And wait a minute  and check you pi's plates. It should be uploaded now


So my suspicion  is that my wifi signal is to weak to do this task I was also having unexpected EOF errors while trying to upload a model and add a plate. But this solution works for me plates get uploaded without error. Plus the pc slices faster than the pi.

I hope this helps someone.

Offline

#2 2021-07-24 06:31:35

Shahin
Administrator
Registered: 2016-02-17
Posts: 3,518

Re: Nano support white brick and unexpected EOF solution

NanoSupport does slice locally, it just get configs from NanoDLP on pi side.

Offline

#3 2021-07-24 22:26:02

Freakyliciousfishy
Member
Registered: 2021-07-21
Posts: 2

Re: Nano support white brick and unexpected EOF solution

I realize this but there is little documentation that explains how to fix my original issue that always just produced a white set of blank slices when I tried to slice in nano support using the pi. The EOF error troubleshooting tipped me off that I was having signal strength errors with the pi. And I was about to give up on printing with resin everything was taking way to long just to setup a file to print and often failed to orient it right when it was successful of slicing..as a shot in dark I decided to download the pc version even though I wasn't going to use it connected to the printer and I started by uploading files to it slicing them then downloading them and moving them to a flash drive and then to the pi. it was a pita process but worked...

there isn't a whole lot of documentation. Here on how to set things up its just assumed that you should know.


Back to the whole trial and error the pi shows up on my network and shows a strong signal... but obviously not well enough..

Offline

Board footer

Powered by FluxBB