You are not logged in.

#1 2020-12-23 12:29:45

Chris-fr63
Member
From: France
Registered: 2019-07-12
Posts: 9

Shutter parameters / speed up print time

Hello to all,

I have a question concerning the Shutter control : I use the shutter config options to switch on/off the LED with the parameter "True/false Signal" selected. It works fine, but I have noticed that in my configuration (with direct control by GPIO) at each layer the LCD panel displays the layer with a delay of approximatively 2 or 3s whereas the LED are already lighted on. I understand that this delay is required to wait the shutter to move to it's open or close position and it's usefull is there is a true shutter connected on the board and not only an electronical relay that have no latence to drive the lighting of the LED.
Maybe I don't use the right parameters in the shutter fields to optimize this step. If there is no possibility to do it in the current version, is there a possibility to consider an futur improvement on this step ? For instance, to have a command "true/false signal" mode for LED and where the using of the fields "Servo Pulse width", Servo Pulse Open, ad Close with min value would not be mandatory. Maybe a more simple way will be to accept a 0 value, instead of 500ms in each field above. I don't know if it could be usefull for many other users ?

Thanks for your advices ...

Offline

#2 2020-12-23 20:41:14

Shahin
Administrator
Registered: 2016-02-17
Posts: 3,429

Re: Shutter parameters / speed up print time

Please, send a debug file.

Offline

#3 2020-12-30 16:22:19

Chris-fr63
Member
From: France
Registered: 2019-07-12
Posts: 9

Re: Shutter parameters / speed up print time

Hello Shahin,

After some new tests the delay that I found between the moment where the shutter is opened (=UV light On)  and the display of the layer was a mistake from my side in the resin profil I had the parameter "wait before print" with a value too high. So the delay now is near 1,5second so I think that it's normal and not too bad.

Offline

#4 2020-12-30 17:08:44

Shahin
Administrator
Registered: 2016-02-17
Posts: 3,429

Re: Shutter parameters / speed up print time

Internal delays on nanodlp should be well below measurable point. So if you still has issue please let me know.
If you disable external calls and cure time to 0.1s and remove any movement sync and waits you should get around 10 layer display per second.

Offline

#5 2021-04-12 17:29:11

elliot
Member
Registered: 2016-04-28
Posts: 79

Re: Shutter parameters / speed up print time

Hi All,
I have an issue with this delay as well. I am not using any delay before print or after. I had an issue with the original servo that started to die- it became very slow to open. I now am using a servo with 0.3ms timing for the action. This means the shutter opens about 0.2 ms faster than the original one - so even with a 0 ms delay the projector screen is on and blank for about 0.25-0.3 seconds before the image is shown on the slide. Is there a way to either synch better or add 0.3s into the program?  Thanks!

Offline

Board footer

Powered by FluxBB