You are not logged in.

#1 2020-03-04 23:28:30

nesquik011
Member
Registered: 2018-08-17
Posts: 43

8.9 inch screen problem

hello guys , i bought like 5 lcds till now 8.9 inch different drivers , all of them are broken and non worked well with me , there is always glitch like display

here is the config i got from the seller

and is there something i can do with advanced settings to fix the problem like drop fresh rate or timing


https://www.aliexpress.com/item/3268464 … 4c4deBHuwk

and that url is the lcd i am using ,
by the way the screen has no damage , no cable damage , i works perfectly on my computer its even looks sharper than my PC LCD










# For more options and information see
# http://www.raspberrypi.org/documentatio … fig-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

hdmi_pixel_freq_limit=300000000
hdmi_timings=2560 0 123 10 50 1600 0 12 4 4 0 0 0 55 0 222183000 0
hdmi_drive=2
disable_overscan=1
max_framebuffer_width=2560
max_framebuffer_height=2560


display_rotate=0
framebuffer_width=2560
framebuffer_height=1600


# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
gpu_mem=128

Offline

#2 2020-03-04 23:31:46

nesquik011
Member
Registered: 2018-08-17
Posts: 43

Re: 8.9 inch screen problem

i have feelings max_framebuffer_width=2560
max_framebuffer_height=2560   is wrong

note ! i did try to drop it to 2599 and 1599  still the same  ,  and i did drop the screen reselution to 2599*1599  as well still nothing at nano dlp

Offline

#3 2020-03-05 21:22:41

nesquik011
Member
Registered: 2018-08-17
Posts: 43

Re: 8.9 inch screen problem

update the only working config 

# DISPLAY SETTINGS
display_rotate=0x10001
hdmi_force_hotplug=1
hdmi_timings=2560 0 123 10 50 1600 0 12 4 4 0 0 0 55 0 222183000 0
hdmi_group=2
hdmi_mode=87
hdmi_pixel_freq_limit=300000000
hvs_priority=0x32ff
max_framebuffer_width=1600
max_framebuffer_height=2560
framebuffer_width=1600
framebuffer_height=2560
framebuffer_depth=24
framebuffer_ignore_alpha=1
config_hdmi_boost=4
gpu_mem=192

#dtoverlay=pi3-miniuart-bt-overlay
dtoverlay=pi3-miniuart-bt
force_turbo=1
enable_uart=1
hdmi_pixel_encoding=2
gpu_mem=128
disable_overscan= 1
dtparam=i2c1=on
dtparam=i2c_arm=on


but the screen is not full size , lets say 70 % of screen size and image looks pretty normal and sharp , so how to fix that ? 

note any other config make the lcd flikering

Offline

Board footer

Powered by FluxBB