You are not logged in.

#1 2020-02-16 20:03:54

mma689
Member
Registered: 2020-02-16
Posts: 2

Problem with image on printer LCD

Hi everybody! I'am a newbie in 3D printing. I have Wanhao D7 (i guess 1.5v) and Raspberry Pi 4. But i cant understand how to start print with NanoDLP. Right now i have problem with image on LCD. I have changed a lot of the configs for display, but i cant see correct picture. My best result - layer blinked one time and disappeared. Can anybody help with config for display?
For example this one config:

# Wanhao D7 nanodlp config
# V1.0 3-feb-2017
# CAMERA SETTINGS ( 1 = ON, 0 = OFF)
#start_x=1
disable_camera_led=1
# DISPLAY SETTINGS
display_rotate=0x10000
hdmi_force_hotplug=1
hdmi_timings=1440 0 50 10 35 2560 0 4 2 2 0 0 0 50 0 198000000 0
hdmi_group=2
hdmi_mode=87
hdmi_pixel_freq_limit=500000000
hvs_priority=0x32ff
max_framebuffer_width=1440
max_framebuffer_height=2560
framebuffer_width=1440
framebuffer_height=2560
framebuffer_depth=24
framebuffer_ignore_alpha=1
config_hdmi_boost=4
gpu_mem=192

wont work. Help me, please

Offline

#2 2020-02-18 01:30:20

bigfilsing
Member
Registered: 2016-11-20
Posts: 206

Re: Problem with image on printer LCD

Hi
Don't worry about being new We all were once!
Setting up the config file can be tricky and there's no 1 solution for all. I have no experience with Raspi 4 
All i can do is share what works for me and hope it helps

# Philm -
# CAMERA SETTINGS ( 1 = ON, 0 = OFF)
#start_x=1
disable_camera_led=1
# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

//hdmi_timings=<h_active_pixels> <h_sync_polarity <h_front_porch> <h_sync_pulse> <h_back_porch> <v_active_lines> <v_sync_polarity> <v_front_porch> <v_sync_pulse> <v_back_porch> <v_sync_offset_a> <v_sync_offset_b> <pixel_rep> <frame_rate> <interlaced> <pixel_freq> <aspect_ratio>

# DISPLAY SETTINGS
gpu_mem=128
hdmi_force_hotplug=1
hdmi_timings=1440 0 50 10 35 2560 0 4 2 2 0 0 0 50 0 198000000 0
hdmi_group=2
hdmi_mode=87
hdmi_pixel_freq_limit=500000000
hvs_priority=0x32ff
max_framebuffer_width=1440
max_framebuffer_height=2560
framebuffer_width=1440
framebuffer_height=2560
framebuffer_depth=24
framebuffer_ignore_alpha=1
config_hdmi_boost=2
dtparam=i2c_arm=on
display_rotate=0

Offline

#3 2020-02-19 11:14:44

mma689
Member
Registered: 2020-02-16
Posts: 2

Re: Problem with image on printer LCD

Hi! I have changed a lot of settings, but it still does not work. I found only one solution - use RPI3. My knowledg about display settings in Linux is not so deep, but i guess problem in drivers.

Offline

#4 2020-02-20 18:26:32

valstudent
Member
Registered: 2020-01-25
Posts: 18

Re: Problem with image on printer LCD

Hello,

I recently had a problem very similar to this and will help to the best of my ability since I have mine working now.

First here is my config file:

#slight overclock
gpu_freq=500
over_voltage=2
hdmi_enable_4kp60=1
#more gpu mem, 64 is std
gpu_mem=256

#ignore any hdmi mode from display
hdmi_ignore_edid=0xa5000080

#Always put out on hdmi
hdmi_force_hotplug=1

#custom hdmi mode
hdmi_group=2
hdmi_mode=87

#DVI mode, no audio output
hdmi_drive=1
config_hdmi_boost=7
#up the freq limit above std
hdmi_pixel_freq_limit=204792000

#timing of the display
hdmi_timings=1440 1 70 35 45 2560 1 12 2 2 0 0 0 50 0 204792000 3

#Overscan settings
disable_overscan=1

#framebuffer settings
framebuffer_width=1152
framebuffer_height=2048
max_framebuffer_width=1152
max_framebuffer_height=2048

#framebuffer_depth=8
#framebuffer_depth=24
#framebuffer_depth=32
#framebuffer_ignore_alpha=1

hvs_priority=0x32ff

dtoverlay=vc4-fkms-v3d

#need below line for nextion display
dtoverlay=pi3-disable-bt
enable_uart=1
dtparam=i2c_arm=on

Next:

sudo apt-get update
sudo apt-get upgrade

Then after doing this all this on the pi through ssh go to your pi's ip address on whatever browser you use.

Then go to Machine Settings and select advanced setup

You will see the Display heading.

There change your horizontal resolution value to 1440 and your vertical value to 2560 and hit submit.

Hope this helped

Offline

Board footer

Powered by FluxBB