You are not logged in.

#1 2019-09-14 13:09:24

qharley
Member
Registered: 2019-04-01
Posts: 4

GLIBC_2.29

Using the latest stable download from the download page I get this message:

./nanodlp: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by ./nanodlp)

I am running Ubuntu 18.04 LTS and cannot update glibc without trouble.
Any advice?

Offline

#2 2019-09-29 09:04:50

monthy_madness
Member
Registered: 2019-09-29
Posts: 1

Re: GLIBC_2.29

Hi,

it's not a bug. the nanodlp was compiled with called glibc version.

for example: i use linux mint 19.2 latest and greatest and have same issue:

sudo ./nanodlp
./nanodlp: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by ./nanodlp)

ldd --version
ldd (Ubuntu GLIBC 2.27-3ubuntu1) 2.27

Therefore we have to wait until glibc 2.29 is available for our systems. And that can be a long time.

It's a pity, that there is no way for getting older versions for us. sad

br
monthy

Offline

#3 2019-09-30 03:05:22

Shahin
Administrator
Registered: 2016-02-17
Posts: 3,400

Re: GLIBC_2.29

Please, try the latest beta see if it working with your OS or not.

Offline

#4 2019-12-02 12:57:12

fcollingwood
Member
Registered: 2017-07-11
Posts: 37

Re: GLIBC_2.29

Shahin wrote:

Please, try the latest beta see if it working with your OS or not.

Link please? The one that can be downloaded from the downloads page doesn't work. Debian is still at 2.28 as are many other distros. It would be good to have a version that works for this version

Offline

#5 2019-12-02 14:23:12

fcollingwood
Member
Registered: 2017-07-11
Posts: 37

Re: GLIBC_2.29

An update to this one. This is a workaround for those running Debian Buster. This may kill your machine so you bear all responsibility for doing this...

Go to https://debian.pkgs.org/ and download the following files:
     libc-l10n_2.29-3_all.deb
     locales_2.29-3_all.deb
     libc6_2.29-3_amd64.deb
     libc-bin_2.29-3_amd64.deb

You can search for them using the search bar at the top of the page. If you are searching, you will need to leave off the _2.29xxxxxxxx (eg, libc-l10n_2.29-3_all.deb becomes libc-l10n). You will find the 2.29 versions under Debian Sid - AMD64 is for any 64 bit machine (AMD OR intel based), i386 is for 32 bit machines

Install them in order by running the following command (You may also need to add --auto-deconfigure to the command if your are prompted for it):
     dpgk -i --force-depends <package name>

Run the following to fix any problems:
     apt --fix-broken install

All of the above assume you are logged in as root. If you are not, prefix each command with sudo.

Last edited by fcollingwood (2019-12-02 14:25:14)

Offline

#6 2021-04-19 07:14:39

Shahin
Administrator
Registered: 2016-02-17
Posts: 3,400

Re: GLIBC_2.29

New NanoDLP build against debian stretch for linux builds, so glibc issue resolved.

Offline

Board footer

Powered by FluxBB