You are not logged in.

#1 2019-06-15 18:13:56

macdarren
Member
Registered: 2017-03-20
Posts: 411

went to update my remote slicer (Ubuntu linux)...missing something

I get this error when I try to run nanodlp

/lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found

I applied all updates to the OS but still having an issue..maybe I need a newer OS release?
Or can I install this somehow...this OS is used for only nano and scad and dropbox so it should be pretty
clean.

Offline

#2 2019-06-16 04:19:26

Shahin
Administrator
Registered: 2016-02-17
Posts: 3,400

Re: went to update my remote slicer (Ubuntu linux)...missing something

Unfortunately new gcc on stock ubuntu 19.04 require glibc 2.29. Require upgrade or manual installation of this library.

Offline

#3 2019-06-16 18:17:38

macdarren
Member
Registered: 2017-03-20
Posts: 411

Re: went to update my remote slicer (Ubuntu linux)...missing something

setup a new 19.04 system and I think I have it going again...

Offline

#4 2021-04-19 07:13:52

Shahin
Administrator
Registered: 2016-02-17
Posts: 3,400

Re: went to update my remote slicer (Ubuntu linux)...missing something

We have ci/cd to build against debian stretch for linux builds, so glibc issue resolved.

Offline

Board footer

Powered by FluxBB